求助:github里的一个R语言包的安装问题

COS论坛 | 统计之都 讨论区 软件应用 S-Plus & R语言 求助:github里的一个R语言包的安装问题

该主题包含 2 条回复,2个帖子,最后由  scorpion20151 月, 3 周 之前 更新。

查看 3 个帖子 - 1 到 3(总计 3 个)
  • 作者
    帖子
  • 1 楼

    scorpion2015
    Participant

    语言包的地址在这里:https://github.com/tommite/libror
    曾尝试直接下载zip压缩包,然后R里加载安装,无果。
    特此请教。

    2 楼

    ®γσ, Lian Hu Eng
    Participant
    >#错误信息。
    > install_github('tommite/libror')
    Downloading GitHub repo [email protected]
    from URL https://api.github.com/repos/tommite/libror/zipball/master
    Error: Does not appear to be an R package (no DESCRIPTION)

    程序包太旧了,何不直接使用程序包内的函数代码https://github.com/tommite/libror/tree/master/R-pkg/ror:?:

    白戸則道:実に面白いですね!
    http://github.com/scibrokes/owner

    3 楼

    scorpion2015
    Participant

    回复 2 楼®γσ, Lian Hu Eng
    多谢回复。
    关于R语言包的安装已通过devtools::install_github(‘tommite/libror/R-pkg/ror’)解决。
    然现在遇到一个新的问题,希望您的帮助:
    所安装的R语言包里有的函数调用了部分Java语句,而这部分java语句在目录https://github.com/tommite/libror/tree/master/src/main下,请问应该将该目录放在本地电脑的什么路径下才能调用?
    希望能得到您的指导。

查看 3 个帖子 - 1 到 3(总计 3 个)

您必须先登录才能回复该主题。