源码安装R遇到不能识别bzip2版本问题

COS论坛 | 统计之都 COS论坛 | 统计之都 软件应用 S-Plus & R语言 源码安装R遇到不能识别bzip2版本问题

Tagged: 

该主题包含 1 条回复,1个帖子,最后由  pengchy5 月 之前 更新。

查看 2 个帖子 - 1 到 2(总计 2 个)
  • 作者
    帖子
  • 1 楼

    pengchy
    Participant

    在Linux下安装R-3.3.2源码,遇到bzip2不能识别问题:

    [[email protected] R_package_archive]$ uname -a
    Linux login 2.6.32-279.el6.x86_64 #1 SMP Wed Jun 13 18:24:36 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux
    [[email protected] R_package_archive]$./configure --prefix=/panfs/home/yangpc/soft/R/R_soft/ --enable-R-shlib  --with-libpth-prefix=/panfs/home/yangpc/soft/ CPPFLAGS="-I/panfs/home/yangpc/soft/lib/packages/bzip2-1.0.6/include/ -I/panfs/home/yangpc/soft/lib/packages/zlib-1.2.8/include/"
    checking zlib.h presence... yes
    checking for zlib.h... yes
    checking if zlib version >= 1.2.5... yes
    checking whether zlib support suffices... yes
    checking mmap support for zlib... yes
    checking for BZ2_bzlibVersion in -lbz2... yes
    checking bzlib.h usability... yes
    checking bzlib.h presence... yes
    checking for bzlib.h... yes
    checking if bzip2 version >= 1.0.6... no
    checking whether bzip2 support suffices...

    这个问题在R邮件列表里都有问过,但是始终没有给出解决方案:
    http://comments.gmane.org/gmane.comp.lang.r.hpc/1719
    http://r.789695.n4.nabble.com/bzip2-td4726112.html
    http://stackoverflow.com/questions/40639138/configure-error-installing-r-3-3-2-on-ubuntu-checking-whether-bzip2-support-suf

    R安装说明里有指出需要bzip2 version 1.0.6:
    https://cran.r-project.org/doc/manuals/r-release/R-admin.html

    2 楼

    pengchy
    Participant

    已经解决了,参考这里:http://stackoverflow.com/questions/40639138/configure-error-installing-r-3-3-2-on-ubuntu-checking-whether-bzip2-support-suf

查看 2 个帖子 - 1 到 2(总计 2 个)

您必须先登录才能回复该主题。